EDINA Digimap Training Exercise: View OS map data in ArcGIS
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Introduction
This guide contains instructions for viewing several types of map data from Digimap Ordnance Survey Collection in ArcGIS.  

You will need access to ArcGIS software to complete all of the exercises in this guide. No prior knowledge of ArcGIS is required.  The instructions and images have been prepared using ArcGIS version 10.1.
What will I learn?

· The key applications used in ArcGIS desktop software
· How to:

· add raster and vector map data to ArcMap

· add point data to ArcMap

· amend symbology of map layers

· select vector map features 

What data do I have?

We have downloaded data from Digimap for you. The data we have downloaded is covered by the following licence:

OS OpenData licence: http://www.ordnancesurvey.co.uk/oswebsite/docs/licences/os-opendata-licence.pdf
We have intentionally downloaded data that is covered by this ‘open’ licence, in order that we can provide data freely with this training exercise. 

Please remember that when you download data from Digimap Collections, the data is typically covered by the Digimap licence(s), meaning that the use of the map data is strictly limited to educational use. 

Familiarise yourself with the Digimap licences here:
http://digimap.edina.ac.uk/webhelp/digimapsupport/about.htm#access/licence_agreements.htm
OpenData folder

You have a folder called OpenData, with some sub-folders. Here’s a summary of the data in these folders:
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· Code Point Polygons - postcode boundaries for the North-East postal region. Downloaded from Digimap OS in Shape file format.
· Layers – layer files, for use with Vector Map District map data, used to apply a cartographic style to the map. Available from Digimap help pages.

· OS Streetview - 1:10000 scale raster map. Downloaded from Digimap Ordnance Survey Collection in TIFF format. 
· Vector Map District (VMD)
· Vector map topographic map data, downloaded in Shape file format from Digimap Ordnance Survey Collection. 

· VMD is provided in 100 x 100 km square tiles from Digimap. We have ‘clipped’ the large tile to a smaller area of Newcastle city centre.
· Gazetteer point data. A selection of place name data for the Newcastle area, downloaded from the Gazetteer Plus service in Digimap OS, in CSV format.

Raster and Vector data
A raster consists of a matrix of cells (or pixels) in a grid, where each cell contains a value representing information, such as temperature. Rasters are scanned maps, digital aerial photographs, satellite imagery or digital photographs. 

Vector map data represents geographic features with points, lines and polygons. Each point is a pair of geographic coordinates. Vector data can store information about the attributes of the map features.
Please read this Ordnance Survey page on raster and vector data:

http://www.ordnancesurvey.co.uk/support/understanding-gis/raster-vector.html
ArcGIS 

ArcGIS is Geographic Information System software that is used to view and analyse geospatial data. 
There are different levels of license for ArcGIS, but all levels include two applications: ArcMap and ArcCatalog. 
· ArcMap is the application you work with to explore and analyse data and make maps. 

· ArcCatalog is the application you work with to manage data. 

Some ArcGIS Desktop products include additional applications, such as:

· ArcToolbox™ - an application that contains many tools for GIS tasks. You can access ArcToolbox from both ArcMap and ArcCatalog.

ArcMap

The ArcMap interface consists of the table of contents on the left and the map display area on the right, as well as a number of toolbars and menus for working with the map and its data. 
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Table of contents

The order of layers within the table of contents is important; the layers at the top of the table of contents draw on top of the layers below them. 
Therefore, you should put the layers that form the background of your map, such as the ocean, at the bottom of the table of contents.

Map display area

There are two views for working with data: data view and layout view. 
You will find buttons to switch between views at the bottom left of the map display area.
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In data view, you explore, edit, query, analyse, and symbolise data. 

In layout view, you arrange data frames and add other map elements, such as scale bars, titles, and legends, to create a map layout that can be published in print or digital form. 

Toolbars

The Standard and Tools toolbars are visible in this screen. Toolbar options are available from View > Toolbars on the main menu. Toolbars can be floating or fixed. 
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ArcCatalog

ArcCatalog is the ArcGIS application designed for browsing, managing, and documenting geographic data. Think of ArcCatalog as a window into your GIS database. From ArcCatalog you can access data stored on your computer's hard drives, local networks, and even the Internet.

To access data, you create a connection to its location (such as a folder on your C: drive). Collectively, the connections you create are called the Catalog.

The Catalog tree, on the left, can be used to browse and preview data.

The preview pane on the right provides three different tabs for previewing information about the data; contents, preview and metadata.  
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ArcToolbox


ArcToolbox provides an organised collection of tools used for GIS analysis, data management, and data conversion.
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The number of tools you have depends on your ArcGIS license. 
Start ArcMap
1. Start ArcMap from your list of programs. 
2. Select New Maps > Blank map.
3. Click OK.
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Import Streetview raster map data
Let’s add the OS Streetview raster map data. 
Raster maps are provided in TIFF image format from Digimap.
These files are straightforward to work with in GIS; they require no preparation or conversion. 
1. Click File > Add Data > Add Data, or the yellow icon with a plus sign on it. [image: image8.png]



2. You may need to connect to the folder that contains your Digimap data. ArcGIS does not automatically see your data folder. Click the Connect to folder button, a yellow folder with a plus sign. [image: image9.png]| g4 By
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3. Select the folder OpenData. 
4. Click OK.
5. Navigate to the folder OpenData > streetview.
6. Use CTRL-click to select all 4 .tif files.
7. Click Add.
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8. If asked to create pyramids, say Yes. 

9. Tick the box ‘use my choice and do not show this dialog…’
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10. If you receive this error, message, click OK:
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In this exercise we will add several different map data files to ArcMap. The table of contents can get quite busy. Let’s create a group layer to contain all of our Streetview data together.  
11. Right-click on Layers.
12. Select New Group Layer.
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13. Now right click on the New Group Layer and select Properties.
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14. Select the General Tab.
15. Type Streetview in the Layer Name box. 
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16. Click OK.

17. Click and drag all the Streetview layers to the new group layer.
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Your ArcMap window should look similar to this:
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18. Save your ArcMap document. Click File > Save as.
19. Name the file and click Save.

Import Code Point Polygons

Code-point polygons are GB postcode boundaries, showing the geographic extent of each postcode unit.  These can be downloaded from Digimap’s Ordnance Survey Collection in Shape file format, which is compatible with ArcGIS and many other GIS software packages.
1. Click Add Data.
2. Navigate to the codepoint-poly folder. Double click on it, then double click NE.  
3. Click ne.shp and click Add.
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You should see a new layer in the Table of Contents area. 
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Our NE.shp file has covered our Streetview data. 
Let’s amend the appearance of the Code Point Polygons layer so we can see the Streetview data too.

Amend Symbology of Code Point Polygons

1. Click once, on the rectangle shape under the text ne in the table of contents:
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The Symbol Selector dialog box will open.

2. Click on the drop down arrow next to Fill Color.

3. Select No Colour.
Now change the border width and colour of the Code Point Polygons, so they will stand out more on our map.

4. Select Outline Width of 2.00.

5. Select an outline colour of your choice, anything that will stand out. We have selected red.
6. Click OK.
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7. Zoom in for a closer look. Is your raster data visible through the Code Point Polygons?
8. Zoom in by moving the scroll wheel on your mouse away from your screen.

9. Or select the Zoom In button from the toolbar, [image: image22.png]


 then click and drag to draw a rectangle over the map where you wish to zoom in. 
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It would be useful to label the polygons with their postcode.

10. Right-click on ne in the table of contents.
11. Click Label Features.
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Postcodes should now have been added to your polygons. 
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For more labelling options, right-click on ne > Properties > Labels.

Import point data

Now we are going to add some point data to our map. This is vector map data.
In your OpenData folder you will see a CSV file, gazetteer_results….CSV
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This file was downloaded from the Gazetteer Plus service in Digimap’s Ordnance Survey Collection. 

The file contains around 90 place names in the Newcastle area, along with their geographic coordinates. 

When we add this data to the map, we will see each place name as a point on the map.
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1. In ArcMap, click File > Add Data > Add XY Data.
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The first step is to identify our CSV file. 
2. Click the Yellow folder icon, navigate to and select the file.
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3. Click Add.
[image: image30.png][Eboundaryline 172413
|E codepoint-poly_172415
(Sprofile-dtm 172017
(Sprofie 172014

| B strectview 172018
[Evmd-vector 172416

gazetteer_resuts_36ae08ce_7664_4017_90d2_7587068>

s 5





4. Select Easting (X) and Northing (Y) as the X and Y fields.

5. Click Edit to identify the coordinate system as British National Grid.
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6. Select Projected Coordinate Systems > National Grids > Europe > British National Grid.
7. Click OK.
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8. Click OK at the Add XY Data box.
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9. Click OK if you see the message Table does not have object-ID field.
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10. We want to view the point data in context; make sure the Streetview layer is displayed. 
11. Uncheck the ne (code point polygons) layer in the Table of Contents so that it is not displayed.

12. You may not be able to see the points, depending on your location.

13. Right click on the gazetteer layer in the Table of Contents.

14. Click Zoom to layer.
15. Your ArcMap window should look similar to this:
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To make our points more visible on our map, we can adjust the symbology.
1. Label the features. Right-click on the layer and select Label Features.
2. Now amend the size and colour of the symbol. In the Table of Contents, click on the dot under the Gazetteer layer.
3. This generates the Symbol Selector box.
The current symbol is only 4.00 points in size and is a dark colour. 

4 Select an alternative – we suggest a bright colour and a size of 10 points or more.

5 Click OK.
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Your symbols should now be more visible.
Import Vector Map District data
Now let’s add our Vector Map District map data. 
1. First, let’s add a New Group Layer in the Table of contents (as we did for Streetview map data).

2. Name the new group layer VectorMapDistrict.
3. Right click your new group layer and click Add Data.
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4. Go to the Vector Map District folder.

5. Select all the Shape files and click Add.
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Note that in the Table of Contents (shown in the image above), the points are added first, then the lines, then the polygon layers and raster layers at the bottom. 

ArcMap imports vector map data in random colours. We will show you how to change the colours.

Depending on your current scale, you may not be able to see the VMD data clearly.  
6. If you cannot see the VMD data, right click on building and select Zoom to Layer.
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7. Uncheck the other map layers, so that you are only displaying VMD. Your map should look similar to the image below.
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Amend Vector Map District symbology

We can apply a cartographic style to the VMD data. There are different methods for doing this. 
Method 1 – Amend symbology using Layer Files

You can apply a pre-defined style to each layer, contained within a layer file. The layer files we will use are specifically for use with VMD. 

We have provided them for you but they are also available from the Digimap help pages: http://digimap.edina.ac.uk/webhelp/os/using_data_with_arcgis/using_vectormap_data/using_vectormap_district.htm
1. In Windows Explorer, double click on the folder layers, supplied in the OpenData folder for this exercise. You will see a list of files. 

There is a layer file for each layer of VMD data. NOTE that we do not have a VMD map layer corresponding to each of theese layer files. 
We only supplied you with 10 layers of map data, when we cropped the original 100 x 100km tile of map data to a more manageable size:
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To apply a layer file.

1. In ArcMap, right click on a layer in the Table of Contents (try road) and select Properties.
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2. Select Symbology, then click Import:
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3. Click on the yellow folder icon.
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4. Now navigate to the layers folder, and click on road.lyr.
5. Click Add.
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6. Click OK.
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7. Set Classifica as the value field to be used. This value in the map attribute data defines the type of road, A road, B road, Motorway etc.

8. Click OK.
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You should now see that there are many different symbols for different road categories in the Symbology tab. 

9. Click Apply and then OK.
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10. If you zoom out, you should be able to see a motorway junction and some of the different road types.

11. You could now go ahead and apply the relevant layer file(s) to some or all of the different layers of VMD you have on your map (you have done road, there are 9 more layers).  Go ahead and try this out if it’s of interest to you.

Method 2 – use attribute data
It is possible to use the attribute date of vector map data to apply symbology.

Try this example for the Public Amenity layer. 

1. Right click public amenity layer in the Table of Contents.

2. Select Open Attribute Table.
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3. Note the column Classifica.

4. This column has entries for the type of public amenity, e.g. hospital, place of worship.
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We can use these entries to apply a different map symbol to each type of public amenity.

5. Close the Attribute Table.

6. Right click the public amenity layer in the Table of Contents.

7. Select Properties.

8. Select Symbology.

9. On the left, select Categories, then Unique Values.

10. Ensure Classifica is selected as the Value Field.

11. Now click Add all values under the box.
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12. You should see the box populated with different symbols.

13. Click Apply.
14. Click OK at the Layer Properties box.

15. Your Table of Contents should now display different symbols for different public amenities.
16. You can change any symbol by clicking on it in the Table of Contents.

17. Click on the Hospital symbol.

18. The Symbol Selector box will open.

19. You can search for different symbol types in the box at the top, e.g. type in hospital and click the search icon.
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20. Select one of the hospital search results.
21. Repeat this for as many public amenity symbols as you wish.

Selecting map features
Let’s imagine we want to find out how many features of a particular type exist in a location, e.g. private roads, within a particular postcode sector (e.g. all postcodes beginning with NE1).
1. Uncheck the boxes next to the Streetview data and the Gazetteer data, to make our map display clearer.
Select postcodes

The first step is to select the postcodes that begin with NE1. 

2. Open the attribute table for NE.
3. Click the first icon on the left at the top of the table.

4. Click Select by Attributes.
[image: image54.png]Table

B af =

AL I S
Find and Replace.
Select By Attibutes
Clear Selection
Switch Selection
Select Al
Add Field,
Tum AllFields On
Show Field Aliases

3 PC_AREA
001625200 [ NE
000se7E30 | NE
o00seTez2 | NE
000857633 | NE
o00se7Ese | NE
000857535 | NE
o00seTEsT | NE
000857539 | NE

000857340





Complete the Select by Attributes box to match the image below – steps:

1. Double click Postcode.
2. Click Like.
3. Type ‘NE1 %’. NOTE: make sure you have a space between NE1 and the % sign. This ensures we only select postcodes that are for the sector NE1. Without a space we would also select NE10, NE11 etc.  

4. Click Apply.
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Some records will be highlighted in blue in the attribute table.
At the bottrom right of the table it tells you how many records are selected.
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5. Close the Select by Attributes dialog box.

6. Close the Attribute table.

The selected postcodes should be highlighted in blue on your map, similar to the image below:

[image: image57.png]Q@ newcastie.mxd - ArcMap lelo(Eh|

File Edit View Bookmarks Insert Selection Geoprocessing Customize Windows Help

DBE& BB X0 (- [ EEE [ o 4 }: of 4
QEEQ i« KW-T K@ 2
Table Of Contents

EEEE]

= £ layers
5 B VectorMapDistrict

424802871 565060432 Unknown Units





Select Private Roads

Next we want to select all Private roads in our road map layer. First we need to work out if  this information is contained in our attribute data.

7. Open the road attribute table.

8. Have a look at the Classifica column. It categorises roads e.g. into Minor Road, B Road etc. One of the categories is Private Road Publicly Accessible, as seen in the image below. 
[image: image58.png]DFTNUMBER CLASSIFICA FEATCODE
Tocalstrest 25760
81318 BRoad 25743
Private Road Pubicly Accessible 25750
‘Minor Road 25750





9. Close the road attribute table.

10. Click Selection  and Select by Attributes at the top of the ArcMap window:
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Complete the Select by Atrributes box to match the image below:

1. Select road as the layer.

2. Double click Classifica.
3. Click Get unique values. The box on the right will populate with the road categories.

4. Click Like.
5. Double click ‘Private Road Publicly Accessible’ from the box on the right (you may need to scroll).
6. Click Apply.
7. Close the Select by Attributes box.
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If we opened the road attribute table, you would see there are now 31 roads selected.
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Select Private Roads with NE1 postcodes

Now we have selected all the Private Roads in our map data, we want to narrow down our selection to the Private Roads with a postcode of NE1.
1. Click Selection and Select by Location at the top of the ArcMap window.
2. The Selection method is ‘select from the currently selected features in’
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3. The target layer is road.
4. The source layer is NE, the postcode boundaries. 

5. Click ‘use selected features’ under Source Layer.
6. Click Apply.

7. Click Close.
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8. Open the attribute table for road, to see that there are 11 private roads with a postcode in the NE1 sector.
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Export your selected records

It would be good to save our selected features, so we can use them again.

1. First, click on List by Selection at the top of the Table of Contents. It’s an arrow icon, as shown in the image below.
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You should be able to see that there are selections in two layers ,NE and road, as seen in the image below.
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We want to save the 11 Private Roads with a postcode starting with NE1.
2. Right click the road layer.

3. Click Create layer from Selected Features.
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4. Now lick List by Drawing Order at the top of the Table of Contents, the icon furthest left.
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You should be able to see a new layer, called road selection.

5. Right click on the road_selection layer.

6. Select Data, then Export Data.
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1. Choose to export All features.

2. Select to use the same coordinate system as the layer’s source data.

3. Click on the yellow folder icon, to select where to save the new data.
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4. Select a suitable folder to save the data. we have chosen the Vector Map District folder.

5. Give the data a meaningful name – we have input private_roads_ne1.


6. Note that there are three file type options at the bottom of the box – select Shapefile.

7. Click Save.
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8. Click OK at the Export Data box.

9. Say Yes to adding the data as a new map layer.
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